Talk:ConTeXt Standalone/Implementation

From ConTeXt wiki

The table

People, you should not be using "latest" in the binaries table. It means nothing. If you compile from svn, please use the svn version id. I am now already unsure what the version of luatex linux-64 is Taco

Experimental setup for Ubuntu

Ubuntu comes with texlive from Feb 2007. That is too old for ConTeXt. I tried to install a parallel tree using the minimals and that failed. So, I tried to merge the minimal tree with texlive. Here are the steps (I am new to linux, so may be doing something really wrong here, use at your own risk)

cd $HOME
rsync -rpzctlv rsync://contextgarden.net/minimals/setup/linux-64/bin .
cd bin
mtxrun --script update --platform=linux-64 --texroot=../tex --update
cd $HOME/tex/texmf-context
rsync -rvzctlp rsync://contextgarden.net'/minimals/current/fonts/new/ minimals/current/fonts/common/ minimals/current/fonts/old/' fonts
cd $HOME/tex/
rsync -rvzctlp rsync://contextgarden.net/minimals/pragma/justtex/texmf-context/ texmf-context
cd $HOME
ln -s tex/texmf-context texmf

cd $HOME/bin
# Make sym-links
 ln -s ../tex/texmf-linux-64/bin/ctxtools ctxtools
 ln -s ../tex/texmf-linux-64/bin/exatools exatools
 ln -s ../tex/texmf-linux-64/bin/luatex luatex
 ln -s ../tex/texmf-linux-64/bin/luatools luatools
 ln -s ../tex/texmf-linux-64/bin/mpost mpost
 ln -s ../tex/texmf-linux-64/bin/mpstools mpstools
 ln -s ../tex/texmf-linux-64/bin/mpto mpto
 ln -s ../tex/texmf-linux-64/bin/mptopdf mptopdf
 ln -s ../tex/texmf-linux-64/bin/mtxrun mtxrun
 ln -s ../tex/texmf-linux-64/bin/pdftex pdftex
 ln -s ../tex/texmf-linux-64/bin/pdftools pdftools
 ln -s ../tex/texmf-linux-64/bin/pdftosrc pdftosrc
 ln -s ../tex/texmf-linux-64/bin/pdftrimwhite pdftrimwhite
 ln -s ../tex/texmf-linux-64/bin/pstopdf pstopdf
 ln -s ../tex/texmf-linux-64/bin/rlxtools rlxtools
 ln -s ../tex/texmf-linux-64/bin/runtools runtools
 ln -s ../tex/texmf-linux-64/bin/texexec texexec
 ln -s ../tex/texmf-linux-64/bin/texfind texfind
 ln -s ../tex/texmf-linux-64/bin/texfont texfont
 ln -s ../tex/texmf-linux-64/bin/texlua texlua
 ln -s ../tex/texmf-linux-64/bin/texluac texluac
 ln -s ../tex/texmf-linux-64/bin/texmfstart texmfstart
 ln -s ../tex/texmf-linux-64/bin/texshow texshow
 ln -s ../tex/texmf-linux-64/bin/textools textools
 ln -s ../tex/texmf-linux-64/bin/texutil texutil
 ln -s ../tex/texmf-linux-64/bin/xetex xetex
 ln -s ../tex/texmf-linux-64/bin/xmltools xmltools
 cp $HOME/tex/texmf-linux-64/web2c/pdftex.pool $HOME/tex/texmf-context/web2c
 

You also need to add a TEXMFCNF=/usr/share/texmf/web2c/ and PATH=$HOME/bin:$PATH in your .bashrc or equivalent file.


Seems to work ok. I will test more, and if it works, maybe copy this information to the main page --Aditya 21:55, 16 December 2007 (CET)

Chinese

We had on TODO list: support for Chinese, see Hans's manual

And here's a user comment:

No need to do this:

  • you have no right to distribute most of the Chinese fonts.
  • some free available fonts are ugly and no one use them.
  • MKIV support font loading, so users can load their chinese fonts in their machine.