From Wiki
Revision as of 19:34, 22 May 2007 by Sanjoy (talk | contribs) (mention where cm-super lives)
Jump to navigation Jump to search

Each successive version of Ubuntu becomes easier to update, which is why the following sections, arranged in reverse chronological order, get successively longer.

Edgy (6.10) and Feisty (7.04)

Unfortunately, you cannot use the repository given in Debian installation because the Debian packages were compiled with a (very very slightly) newer libc6 than the one that ships with Ubuntu 7.04. Here instead are slightly tested packages backported for Ubuntu 6.10 (edgy); they have also been working on my Feisty (7.04) laptop. Put these two lines in your /etc/apt/sources.list:

  deb     http://web.mit.edu/download/sanjoy/texlive-backports/ edgy/
  deb-src http://web.mit.edu/download/sanjoy/texlive-backports/ edgy/

Then you can install the texlive 2007 and recent context packages. See the Debian installation instructions for the details, but here is the quickstart:

 apt-get update
 apt-get install cm-super texlive-fonts-recommended context context-nonfree context-doc-nonfree

That command also installs the needed texlive packages for pdftex, metapost, lmodern etc. The cm-super package is in the universe repository so you'll need that enabled in your sources.list. You should not need to chase down the old teTeX 3.0 packages, which will be removed automatically by the above installation line. To test whether the basics of ConTeXt are working after the upgrade, try:

 ctxtools --contextversion

Let me (Sanjoy) know if you find anything broken.

Dapper (6.06)

Backporting from gutsy (7.10) results in a circular dependency, so I gave up on that plan as too hard. However, Ubuntu 6.06 contains teTeX 3.0 (including ConTeXt 2005.01.31), so you can just install tetex-extra and use ConTeXt. However, once you got your feet wet, you will probably want to install a more recent pdfTeX than the 1.21a installed with Ubuntu (since ConTeXt can give you more features with newer pdfTeX's), so again, please follow the instructions for TeTeX_3.0 installation.

The instructions for Fedora Core 5 are valid for Ubuntu 6.06, with a few caveats:

  • Ubuntu's default installation lacks a few tools that you'll need to build a new version of pdfTeX and to run new versions of ConTeXt. So before upgrading, do:
 sudo apt-get install build-essential bison flex ruby 
  • The configuration files that users should edit are under /etc/texmf/texmf.d. Do not edit the .cnf files in /usr/share/texmf/web2c directly; instead, edit the configlet files in the .d directory and run update-texmf or update-updmap.

After doing all of the above, the new versions seem to be working:

% texexec --version

 TeXExec 5.4.3 - ConTeXt / PRAGMA ADE 1997-2005

               texexec : TeXExec 5.4.3 - ConTeXt / PRAGMA ADE 1997-2005
               texutil : TeXUtil 9.0.1 - ConTeXt / PRAGMA ADE 1992-2006
                   tex : pdfTeX, 3.141592-1.40.0-beta-20060213 (Web2C 7.5.5)
               context : ver: 2006.04.23 23:55
               cont-en : ver: 2006.04.23 23:55  fmt: 2006.4.24  mes: english

Breezy (5.10)

Breezy's support ends in April 2007, so you are advised to upgrade (one Ubuntu release at a time) to a more recent release in order to run a secure system; Dapper (6.06) will be supported until 2009, so that could be a good choice. The following instructions are for those who cannot (or do not wish to) upgrade.

Ubuntu 5.10 does not include a TeX installation by default. The distribution that you get when you install TeX is teTeX-2.0.2, which is too old and will not work with recent ConTeXt versions. So you should not install it, but follow the instructions for TeTeX_3.0_installation. However, you first must install supplementary packages not included in Ubuntu by default (and I hope I'm not forgetting anything; a number of dependencies will automatically be installed as well):

 # sudo apt-get install build-essential bison flex libncurses5-dev ruby

Install these packages before trying to compile teTeX 3.0 or running newer ConTeXt release (which use ruby rather than perl), or you will get errors during the compilation or have problems running the results.